<!DOCTYPE HTML PUBLIC "-//W3C//DTD HTML 4.01 Transitional//EN" "http://www.w3.org/TR/html4/loose.dtd">
<HTML>
<HEAD>
<TITLE>Seattle Press</TITLE>
<META HTTP-EQUIV="Content-Type" content="text/html; charset=ISO-8859-1">
<META name="Description" content="Seattle Press is a digest of news from greater Seattle. It also contains the archive of the online editions of the former Seattle Press 1998-2003. We have a community calendar, business directory, online ads, discussion forums, and more.">
<META name="Keywords" content="seattle, news, newspaper, seattle press, washington, puget sound, calendar, directory, traffic, weather, business, schools, churches, advertising, classifieds">
<META name="Abstract" content="Seattle Press is a publication of Clark Internet Publishing. The former Seattle Press ceased publication and distribution of its printed newspaper after October 3, 2003. There is no corporate tie between the two entities.

Clark Internet Publishing managed technical services for the online editions of The Seattle Press from 1998 to 2003. We created the online edition using our Journalmaker package. When the SP ceased publication we retained the archive, which we are making available to about 10,000 readers per week as a public service and as a demonstration of our publishing platforms. Several features of the site are open to the public for dissemination of news and opinion.

The Calendar allows readers to post events, subject to review by the administrator. Events must be family friendly. Events that carry an admission charge may be subject to a small publicity fee. Events can be single-day, serial, or recurrent. The Calendar uses the standard 'iCalendar' format and can link to other calendars of regional interest. If you know of a Puget Sound oriented iCalendar, send information using the To The Editor form in the Contents.

The Forums are available for discussion of local issues. Many articles carry a comment form, so you can weigh in on topics of interest to you. Recent comments are summarized in the Feedback page.

Please note: All responsibility for editorial content for material published before September 1, 2004, rests with the former publishers and authors. Comments posted in the forums or in the directory or free classifieds are the responsibility of their authors. Caveat Lector!">
<META name="Copyright" content="Portions 1998-2003 © The Seattle Press. Design and content posted after September 2003 © Clark Internet Publishing unless otherwise attributed.">
<META name="Generator" content="Sitemaker, by Clark Internet Publishing.">
<META name="Robots" content="index,follow">

<link title="normal" href="http://www.seattlepress.com/css/main.css" type="text/css" rel="stylesheet">

<script src="http://www.seattlepress.com/js/SM_common.js" language="JavaScript1.2" type="text/javascript"> </script>


 <!--  ******  CUSTOM SITE HEAD CONTENT  ******   -->

<!-- mobile device adjustments -->
<meta name="viewport" content="width=device-height, initial-scale=1">

<div style="position:absolute; top: 30px; right:5%;"><a href="#" style="color: #336699; font-size:18pt;" onclick="alert('The site is best viewed holding your device horizontally. We are adapting the site as rapidly as possible for mobile devices, but some pages may require that you reposition the view by pushing or tapping.'); return false;">MOBILE?</a></div>


<script type="text/javascript">
<!-- formatting

function showDiv(divName){
alert('show '+divName);   				
	document.getElementById(divName).style.display="block";
}

function hideDiv(divName){
alert('hide'+divName);
	document.getElementById(divName).style.display="none";
}

function showHideDiv(divName) {
	styleObj=document.getElementById(divName).style;
	if(!styleObj.display || styleObj.display == "none") {
		styleObj.display = "block";
	}else{
		styleObj.display = "none";
	}
//alert (styleObj.display);
}

-->
</script>



<script type="text/javascript">
<!--
// event_related

function viewEvent() {
   var w = document.choose_event.event_list.selectedIndex;
   var myLoc = document.choose_event.event_list.options[w].value;
   window.location = "/tools/members.dwp?task=member_event&event_id="+myLoc;
}


// following should be at Sm system level
function setDateNow(myField) {
//alert(myField);
	var d = new Date();
//alert(d);
	var curr_date = d.getDate();
	var curr_month = d.getMonth() +1;
	var curr_year = d.getFullYear();
	theDate.value = curr_year+"-" + curr_month + "-" + curr_date;
//	document[myField]write(curr_date + "-" + curr_month + "-" + curr_year);
//	alert(myField+" "+theDate);
	document.forms.rsvp_form[myField].value = theDate.value;
}

function enable_sign_up_submit() {
// enables/disables form submit button when 
// accept_terms checkbox ON and
// user indicates real person (opt. use captcha)
//	alert("enable_sign_up_submit");
	var frm = document.forms.sign_up;
	antispam_input = document.forms[0].spamtrap.value;
//	alert ("asi="+antispam_input);
	if(
	frm.loginname.value != ''
	&& frm.newpass1.value != ''
	&& frm.newpass2.value != ''
	&& frm.email.value != ''
	&& antispam_input != ''
	&& frm.accept_terms.checked
	) {
		frm.submitButton.disabled = false;
	}else{
		frm.submitButton.disabled = true;
	}
}

// swaps font sizes
function set_font_size(e,n) {
document.getElementById(e).style.fontSize = n;
window.scrollTo(0,0)
}

function popChatWindow(){
	myChat = document.mychatcall;
	pop_win("",600,600);
	myChat.submit();
}

function validate_class_selection(){
	frm = document.forms.select_year;
	if(frm.category.value){
		frm.submit();
	}else{
		alert('Please choose a year.');
	}
}

function showcartform()
{
pop_win('',800,450);
document.mycartform.submit();
}


function pop_win(my_url,my_width,my_height){			
	my_params ='WIDTH=' + my_width + ',HEIGHT=' + my_height + ',screenX=200,screenY=200,top=200,left=200,toolbar=0,scrollbars=1,location=0,statusbar=0,menubar=0,resizable=1';
	
	//'toolbar=0,scrollbars=1,location=0,statusbar=0,menubar=0,resizable=1,width=400,height=400,left = 100,top = 100'
	// open window and bring to front
	popWindow = window.open(my_url,'popWindow',my_params);
	popWindow.window.focus();
}

-->

</script>


 <!--  ******  CUSTOM THEME CSS CONTENT  ******  -->

<style type="text/css">

.submission_box {
margin:20px;
padding:10px;
border: 1px solid #336699;
}

#mastcontent {
background-repeat: no-repeat;
background-position: 0 bottom;
border-bottom: 1px solid #AACCFF;
}

.SM_banner_ad_title,
.SM_banner_ad_link {
background:#CDE;
}
.SM_banner_ad_info {text-align: left;}

.SM_component_blog_post_title { margin:0; padding:0; }

.SM_blog_view_post_footer{
  padding-bottom:1px;
   text-align:right;
}


.SM_component_blog_post {
margin-bottom: 5px;
}

.SM_hide_name { font-style: italic; font-size:100%; color:#369;}

.pct80{font-size:80%;}

.SM_calendar_quicklist_title {
font-size:90%;
font-weight:bold;
}
.SM_calendar_quicklist_date {
font-size:80%;
padding-left:10px;
}
.SM_calendar_quicklist_info {
font-size:80%;
padding: 10px;
padding-bottom:0;
}

body {
background-position: left bottom;
background-repeat: no-repeat;
}

.SM_member_bar_div table {
padding-right:10px;
}

/*
#mainbody {
border-top: 1px solid #CCCCCC;
border-right: 1px solid #CCCCCC;
}
*/

#SM_link_229 {
margin-bottom: 10px;
}

td .SM_site_menu_no_link {
padding-top: 10px;
font-size:95%;
color: #336699;
text-align: center;
/*border_bottom: 1px solid #336699;*/
}

#SM_link_4972 {
margin-top:20px;
}

#SM_top_menu_content {
border-top: 1px solid #336699;
border-bottom: 1px solid #336699;
}

#navigation { 
padding-top:144px; 
/*border-right: 1px solid #DDEEFF;*/
background-repeat: no-repeat;
}

</style>



 <!--   ******   CUSTOM PAGE HEAD CONTENT   ******   -->

<style type="text/css">

.indented {margin-left: 2%; margin-right:2%;}
.centered {margin:0 auto;}

.SM_blog_lead {
margin-top:20px;
margin-left:20px; margin-right:20px;
font-size:14px; font-family: verdana,sans-serif;
}
.SM_blog_lead_title {font-size:24px; font-weight:bold; }

.SM_comment_more_link { padding-left: 40px; }

#SM_comp_17233 dl {margin:0;}

.SM_section_title {
margin-top:0; margin-bottom:3px;
border-bottom: 3px solid #99CCFF;
}

.SM_comp_ad {
padding-top: 2px;
padding-bottom: 2px;
}

</style></HEAD>

<BODY bgcolor="#336699"  text="#333333" >

<!--  ******   START OVERALL PAGE TEMPLATE TABLE   *****  -->


<table summary="" id="mainbody" class="SM_mainbody_table"  align="center" width="96%" cellpadding="0" cellspacing="0" border="0" >

<!--  *************  MEMBER BAR TEST  location: 1  ***********   -->

<!--  ******   MEMBERS   *****  -->


<TR><td  id="member_bar_section" class="SM_member_bar"  colspan="2" height="18px"><div class="SM_member_bar_div" ><TABLE summary="" border="0" cellpadding="0" cellspacing="0"><TR><TD><a href="http://www.seattlepress.com/tools/members.dwp?task=new_member">Register</a>-<a href="http://www.seattlepress.com/tools/members.dwp?task=log_in&amp;r_label=Return&amp;r_url=http%3A%2F%2Fwww.seattlepress.com%2F%3Furlid%3Dsprs%26page_code%3Dhome">Sign&nbsp;In</a>&nbsp;<a href="/"><img src="http://sitemaker.clark-ip.com/graphics/icons/home_red18px.png" style="vertical-align: middle;" title="home" alt="home"></a>&nbsp;</TD></TR></TABLE></div></TD></TR>

<TR>

		<td id="mastcontent" class="SM_mast_content"   align="left" valign="middle" height="48" width="100%" bgcolor="#AADDFF">

	

<!--  ******   START SITE TITLE SECTION   *****  -->



<!--  ******   TEST  current_theme_id = 141   *****  -->

<!--  *************  MEMBER BAR TEST  location: 2  ***********   --><div class="SM_mast_title" ><IMG  ID="SM_graphic_6388"  SRC="http://www.seattlepress.com/graphics/sprs_f26ad9ceabec.png" width="396" height="48"  ALT="Seattle Press"  BORDER="0"></div><!--  *************  MEMBER BAR TEST  location: 3  ***********   -->

<!--  ******   END SITE TITLE SECTION   *****  -->


	</TD>
	
</TR><TR>	
	
	<td id="SM_top_menu_content" class="SM_top_menu_section_style"  align="center" valign="top" height="18" bgcolor="white" >
		
	
<!--  ******   START TOP MENU SECTION   *****  -->

<!--  *************  MEMBER BAR TEST  location: 6  ***********   -->

<!--  ******   START TOP MENU LINKS   *****  -->



<TABLE summary=""  align="center"  width="95%"  cellpadding="0" cellspacing="0" border="0"  id="SM_top_menu_table" class="SM_top_menu"><TR>
<TD   ID="SM_top_menu_item_active" onclick="location.href='http://www.seattlepress.com'" class="SM_top_menu_item" width="12%" >
<div class="SM_site_menu_text_indent_0"><a  href="http://www.seattlepress.com">INDEX</a></div></TD>
<TD   ID="SM_link_top_4796" onclick="location.href='http://www.seattlepress.com/tools/blog.dwp?t=1514488824'" title="News from the Puget Sound with links to other news outlets."  class="SM_top_menu_item" width="12%" >
<div class="SM_site_menu_text_indent_0"><a  href="http://www.seattlepress.com/tools/blog.dwp?t=1514488824">News Digest</a></div></TD>
<TD   ID="SM_link_top_935" onclick="location.href='http://www.seattlepress.com/tools/calendar.dwp?calendar_id=2&amp;t=1514488824'" title="Advertise free events in Seattle at no charge. Increase visibility when you sponsor the calendar."  class="SM_top_menu_item" width="12%" >
<div class="SM_site_menu_text_indent_0"><a  href="http://www.seattlepress.com/tools/calendar.dwp?calendar_id=2&amp;t=1514488824">Calendar</a></div></TD>
<TD   ID="SM_link_top_769" onclick="location.href='http://www.seattlepress.com/tools/directory.dwp?directory_id=6&amp;t=1514488824'" title="Get recognized! Add your Seattle or Puget Sound business to our Directory."  class="SM_top_menu_item" width="12%" >
<div class="SM_site_menu_text_indent_0"><a  href="http://www.seattlepress.com/tools/directory.dwp?directory_id=6&amp;t=1514488824">Directory</a></div></TD>
<TD   ID="SM_link_top_4967" onclick="location.href='http://www.seattlepress.com/transportation.html'" class="SM_top_menu_item" width="12%" >
<div class="SM_site_menu_text_indent_0"><a  href="http://www.seattlepress.com/transportation.html">Transportation</a></div></TD>
<TD   ID="SM_link_top_4968" onclick="location.href='http://www.seattlepress.com/weather.html'" class="SM_top_menu_item" width="12%" >
<div class="SM_site_menu_text_indent_0"><a  href="http://www.seattlepress.com/weather.html">Weather</a></div></TD>
<TD   ID="SM_link_top_6786" onclick="location.href='http://www.seattlepress.com/members.html'" class="SM_top_menu_item" width="12%" >
<div class="SM_site_menu_text_indent_0"><a  href="http://www.seattlepress.com/members.html">Members</a></div></TD>
<TD   ID="SM_link_top_4471" onclick="location.href='http://www.seattlepress.com/tools/form.dwp?form_id=257&amp;t=1514488824'" title="Write to the editor."  class="SM_top_menu_item" width="12%" >
<div class="SM_site_menu_text_indent_0"><a  href="http://www.seattlepress.com/tools/form.dwp?form_id=257&amp;t=1514488824">Contacts</a></div></TD>
</TR></TABLE>



<!--  ******   END TOP MENU LINKS   *****  -->

<!--  *************  MEMBER BAR TEST  location: 7  ***********   -->
<!--  ******   END TOP MENU SECTION   *****  -->

		
	</td>
	
</TR><TR>	

			
	<td id="content_section" class="SM_page_content" valign="top"  bgcolor="white" width="100%">

		

<!--  ******   START CONTENT SECTION   *****  -->


<!--  *************  MEMBER BAR TEST  location: 4  ***********   -->
<div id="content_section_div"  class="SM_page_content_div">
<div id="content_margin_div"  class="SM_content_margin_div">
<div ID="content_box" CLASS="SM_content_box_div">

<!--  ******  START COMPONENT - ID:29617  TYPE:container_start   *****  -->


<TABLE summary="" CELLSPACING="0"   WIDTH="99%"  CELLPADDING="0"   CLASS="SM_comp_container_start" ID="SM_comp_29617"><TR><TD  ALIGN="center"><DIV  CLASS="SM_comp_content">
<br clear="all">

<!--  ******  START COMPONENT - ID:26100  TYPE:container_start   *****  -->


<TABLE summary="" CELLSPACING="0"  ALIGN="left"  WIDTH="22%"  CELLPADDING="0"  STYLE="margin-right:3%;"  CLASS="SM_comp_container_start" ID="SM_comp_26100"><TR><TD >
<P  class="SM_section_title" ID="SM_section_title_26100">Inside...</P>
<DIV  CLASS="SM_comp_content">


<!--  ******  START COMPONENT - ID:26099  TYPE:text   *****  -->



<DIV    CLASS="SM_comp_text" ID="SM_comp_26099" >

<DIV  CLASS="SM_comp_content">
<p><b>Got News?</b> <a href="http://www.seattlepress.com/tools/form.dwp?form_id=257">Submit</a> articles and photos.</p></DIV>

</DIV>



<!--  ******  END COMPONENT  - ID:26099  TYPE:text   *****  -->




<!--  ******  START COMPONENT - ID:24967  TYPE:text   *****  -->



<DIV    CLASS="SM_comp_text" ID="SM_comp_24967" >

<DIV  CLASS="SM_comp_content">
<div align="center" class="SM_section_title" style="margin-top: 10px; font-size:110%;">Upcoming Events and Shows</div><div id="calendar_preview"><div>September 29, 2017 -- The Last 5 Years</div><div>October 14, 2017 -- Arts North! Studio Tour</div><div>November 18, 2017 -- The Life-Changing Power Of Memoir Writing</div><div style="text-align:center; margin-top:5px;"><a href="/tools/calendar.dwp?calendar_id=24</a>">Open the Calendar</a></div></div></DIV>

</DIV>



<!--  ******  END COMPONENT  - ID:24967  TYPE:text   *****  -->




<!--  ******  START COMPONENT - ID:13363  TYPE:text   *****  -->



<DIV    CLASS="SM_comp_text" ID="SM_comp_13363" >

<DIV  CLASS="SM_comp_content">
<dl class="directory_view_dl" style="margin:0; padding:0;"><dt><a target="directory_link" href="http://forixseattle.com">Forix</a><dd class="directory_view_dd">Seattle based web design firm....<dt><a target="directory_link" href="http://www.amnw.org">Academy Of Music Northwest</a><dd class="directory_view_dd">A leading music school in Washington State, The Academy of Music Northwest provi...<dt><a target="directory_link" href="http://towncarseatac.googlepages.com">Town Car of SeaTac</a><dd class="directory_view_dd">Day and night our luxury service connects all of Bellevue, Seattle, and Tacoma. ...<dt><a target="directory_link" href="http://www.injurytriallawyer.com">Davis Law Group</a><dd class="directory_view_dd">Personal injury attorneys: car accidents, wrongful death, etc. Forcing insurance...<dt><a target="directory_link" href="http://www.towncarcentral.com">Town Car Central</a><dd class="directory_view_dd">Executive sedan / car for hire / town car service. Airport 'limo' transportation...</dl></DIV>

</DIV>



<!--  ******  END COMPONENT  - ID:13363  TYPE:text   *****  -->


<br clear="all">

<!--  ******  START COMPONENT - ID:13850  TYPE:ad   *****  -->


<TABLE summary="" CELLSPACING="0"  ALIGN="center"  WIDTH="90%"  CELLPADDING="0"   CLASS="SM_comp_ad" ID="SM_comp_13850"><TR><TD  ALIGN="center"><DIV  CLASS="SM_comp_content">
<div class="SM_banner_ad_text_box"  onclick="parent.location='http://sitemaker.clark-ip.com/util/ad_click.dwp?ad=81'" ><div class="SM_banner_ad_content" ><div class="SM_banner_ad_title"><A HREF="http://sitemaker.clark-ip.com/util/ad_click.dwp?ad=81" >Be the Next Lois Lane!</A></div><div class="SM_banner_ad_info">Got News? Use the To The Editor form on this page. To become a regular reporter and earn a by-line and more, click this ad's title.</div><div class="SM_banner_ad_link"><A HREF="http://sitemaker.clark-ip.com/util/ad_click.dwp?ad=81" >seattlepressonline.com</A></div></div></div></DIV></TD></TR></TABLE>



<!--  ******  END COMPONENT  - ID:13850  TYPE:ad   *****  -->


<br clear="all">

<!--  ******  START COMPONENT - ID:19437  TYPE:text   *****  -->



<DIV    CLASS="SM_comp_text" ID="SM_comp_19437" >

<DIV  CLASS="SM_comp_content">
<p><a href="http://www.reesclark.com/757284627.html" style="color:white; font-size:3px; text-decoration:none;">Lutefisk</a></p></DIV>

</DIV>



<!--  ******  END COMPONENT  - ID:19437  TYPE:text   *****  -->




<!--  ******  START COMPONENT - ID:31123  TYPE:text   *****  -->



<DIV    CLASS="SM_comp_text" ID="SM_comp_31123" >

<DIV  CLASS="SM_comp_content">
<div onclick="window.location.href='http://www.seattlepress.com/tools/form.dwp?form_id=257';" style="border:1px solid gray; padding:5px;">
<marquee>Become a neighborhood reporter. Click here to contact the editors.</marquee>
</div></DIV>

</DIV>



<!--  ******  END COMPONENT  - ID:31123  TYPE:text   *****  -->


</DIV></TD></TR></TABLE>



<!--  ******  END COMPONENT  - ID:26101  TYPE:container_end   *****  -->




<!--  ******  START COMPONENT - ID:29977  TYPE:container_start   *****  -->


<TABLE summary="" CELLSPACING="0"   WIDTH="75%"  CELLPADDING="0"   CLASS="SM_comp_container_start" ID="SM_comp_29977"><TR><TD ><DIV  CLASS="SM_comp_content">


<!--  ******  START COMPONENT - ID:28384  TYPE:text   *****  -->



<DIV    CLASS="SM_comp_text" ID="SM_comp_28384" >

<DIV  CLASS="SM_comp_content">
<div id="blog_lead_view" class="blog_lead_view"><div id="blog_lead_title" class="SM_section_title" style="margin-bottom:0.5em; font-size: 200%;"><a href="tools/blog.dwp?task=show_post&post_id=6382" style="text-decoration:none;">TRUMP TOWER MOSCOW 'Net Domain Renewed During, After Campaign</a> </div><div style="float:right; margin-left:5px;"></div><div>Pres. Trump has claimed that he had no pending deals in Russia after the beginning of his presidential campaign. Yet consider the Internet domain <b>trumptowermoscow.com</b>. It was registered in 2008 by "The Trump Organization" and has been renewed annually including three times (2015, 2016 and 2017) since the presidential campaign of 2016 began.<br>
<br>
If indeed the project was to end before the election campaign of 2016 as Pres. Trump has asserted, why would registrants renew the related domain afterward, most recently in July 2017, through 2018? It certainly contradicts the statement that the candidate had no pending deals in Russia. It would appear that someone within The Trump Organization is at the very least hedging his bet, and as everyone knows, that "organization" is totally controlled by one person.<br>
<br>
Two reasons for the contradiction suggest themselves: Either (a) that oft-cited, unnamed "low ranking employee who is no longer with the company" failed in his/her responsibility to cancel it, or (b) there was never any intent to abandon the project unless the presidential bid faiiled. Take your choice.<br>
<br>
Of course there may be other possible reasons for the unnecessary rene... ...<a href="tools/blog.dwp?task=show_post&amp;post_id=6382">Read complete article</a>...</div></DIV>

</DIV>



<!--  ******  END COMPONENT  - ID:28384  TYPE:text   *****  -->


<br clear="all">

<!--  ******  START COMPONENT - ID:24994  TYPE:container_start   *****  -->


<TABLE summary="" CELLSPACING="0"  ALIGN="left"  WIDTH="48%"  CELLPADDING="0"  STYLE="padding-left:1%; padding-right:3%;"  CLASS="SM_comp_container_start" ID="SM_comp_24994"><TR><TD ><DIV  CLASS="SM_comp_content">


<!--  ******  START COMPONENT - ID:28382  TYPE:member_journal_view   *****  -->


<TABLE summary="" CELLSPACING="0"    CELLPADDING="0"   CLASS="SM_comp_member_journal_view" ID="SM_comp_28382"><TR><TD >
<P  class="SM_section_title" ID="SM_section_title_28382">The Blurt Board</P>
<DIV  CLASS="SM_comp_content">
<div class="member_journal_preview"><div><a name="postbody7432"></a><div style='margin-top:5px; padding-left:10px; text-indent:-10px; padding-bottom:5px; border-bottom:1px solid #999; margin-bottom:10px;'><div><div><span style="border-bottom: 1px solid #999;">Rees Clark  <span style="font-size:80%;">( <span style="font-size:80%;">27-Dec-2017</span> )</span></div><div><i>Pres. Trump has not denied that if he is not invited to the royal wedding he will declare the US independent of the British crown.</i> </div></div><br clear="right"></div></div><div><a name="postbody7396"></a><div style='margin-top:5px; padding-left:10px; text-indent:-10px; padding-bottom:5px; border-bottom:1px solid #999; margin-bottom:10px;'><div><div><span style="border-bottom: 1px solid #999;">MadArt Seattle  <span style="font-size:80%;">( <span style="font-size:80%;">20-Jul-2017</span> )</span></div><div><i>The Open House and Artist Talk for "Super Natural" by Jennifer Angus will be Sunday, July 30th from 1-4pm, with the Artist Talk at 2pm. Free and open to the public at MadArt Studio.</i>  <span style="font-size:90%;"><a target="member_journal_more" href="http://madartseattle.com/events/super-natural-open-house-artist-talk/">LINK</a></span></div><div style="text-align:center; margin-bottom: 5px;"><a target="update_image" href="http://madartseattle.com/wp-content/uploads/IMG_7255-closeup-1050x500.jpg"><img src="http://madartseattle.com/wp-content/uploads/IMG_7255-closeup-1050x500.jpg" style="text-align:center; padding:5px; width:90%;" title="Click to view at original size in new window; close that window to return here."></a></div></div><br clear="right"></div></div><div><a name="postbody7383"></a><div style='margin-top:5px; padding-left:10px; text-indent:-10px; padding-bottom:5px; border-bottom:1px solid #999; margin-bottom:10px;'><div><div><span style="border-bottom: 1px solid #999;">Susie Starrfield  <span style="font-size:80%;">( <span style="font-size:80%;">7-Mar-2017</span> )</span></div><div><i>Creative Age Festival of Edmonds (“CAFE”)
Saturday, April 29th, 2017    8am-7pm
Edmonds Senior Center, Downtown Edmonds 
220 Railroad Avenue
www.creativeagefestival.org  
</i>  <span style="font-size:90%;"><a target="member_journal_more" href="http://www.creativeagefestival.org">LINK</a></span></div></div><br clear="right"></div></div><div><a name="postbody7377"></a><div style='margin-top:5px; padding-left:10px; text-indent:-10px; padding-bottom:5px; border-bottom:1px solid #999; margin-bottom:10px;'><div><div><span style="border-bottom: 1px solid #999;">Frank Alexander  <span style="font-size:80%;">( <span style="font-size:80%;">23-Feb-2017</span> )</span></div><div><i>Testing updates.</i> </div></div><br clear="right"></div></div><div><a name="postbody7348"></a><div style='margin-top:5px; padding-left:10px; text-indent:-10px; padding-bottom:5px; border-bottom:1px solid #999; margin-bottom:10px;'><div><div><span style="border-bottom: 1px solid #999;">Mary Margaret Briggs  <span style="font-size:80%;">( <span style="font-size:80%;">27-Oct-2016</span> )</span></div><div><i>Vashon Island Art Studio Tour is a free, self-guided event featuring 80+ artists at 34 studios. Visitors will explore an amazing range of artwork and may purchase directly from the artists.</i>  <span style="font-size:90%;"><a target="member_journal_more" href="www.vashonislandartstudiotour.com">LINK</a></span></div></div><br clear="right"></div></div><div><a name="postbody837"></a><div style='margin-top:5px; padding-left:10px; text-indent:-10px; padding-bottom:5px; border-bottom:1px solid #999; margin-bottom:10px;'><div><div><span style="border-bottom: 1px solid #999;">Sasha McGuire  <span style="font-size:80%;">( <span style="font-size:80%;">15-Jul-2013</span> )</span></div><div><i>Getting excited to travel to Woodinville Lavender and seeing and smelling a field of lavender!</i> </div></div><br clear="right"></div></div><div><a name="postbody655"></a><div style='margin-top:5px; padding-left:10px; text-indent:-10px; padding-bottom:5px; border-bottom:1px solid #999; margin-bottom:10px;'><div><div><span style="border-bottom: 1px solid #999;">Icono Clast  <span style="font-size:80%;">( <span style="font-size:80%;">24-Feb-2012</span> )</span></div><div><i>It's simple if you're a corporate "leader": (1)&nbsp;Hold wages down with unfair labor practices; (2)&nbsp;Manipulate legislators with donations and dogma to hold taxes down; (3)&nbsp;Keep a growing share of national income.</i> </div></div><br clear="right"></div></div><div><a name="postbody80"></a><div style='margin-top:5px; padding-left:10px; text-indent:-10px; padding-bottom:5px; border-bottom:1px solid #999; margin-bottom:10px;'><div><div><span style="border-bottom: 1px solid #999;">vidya sagar  <span style="font-size:80%;">( <span style="font-size:80%;">25-Mar-2010</span> )</span></div><div><i>Buying Seattle Condos---Research Its Neighborhoods First</i>  <span style="font-size:90%;"><a target="member_journal_more" href="http://seattle-condos.newcondosonline.com/seattle-condos/">LINK</a></span></div></div><br clear="right"> <div id="postbody80" style="display:none;"> <div style="margin-top:5px; font-weight:bold;"></div> <div>If you are going to buy condo property in a city where iconic Jimmy Hendricks and Bruce Lee lived, in a city where grunge rock was born and in a city, where Bill Gates, Microsoft and coffee have become the way of life for ordinary citizens, you must first learn about its many beautiful neighborhoods.  Northwest’s Emerald City, Seattle has a collection of fine residential neighborhoods, each having its own unique culture and community feel, parks and businesses and its collection of world class condos. If you want to enjoy the true charms of this city with panoramic views, you must come to live in one of the high rise Seattle condos. Most of these properties offer magnificent views of lofty Olympic mountain range or majestic Mount Rainier, of beautiful Puget Sound and the San Juan Islands. Nation’s most educated city, Seattle offers its residents the most interesting urban lifestyle with opportunities ranging from golfing to skiing, camping to kayaking and sailing to hiking. When it comes to take pleasure in typically urban entertainments, the Northwest’s art and music capital does not lag behind. The city has a number of world class restaurants, chic shopping malls and an exciting night life. No wonder, Seattle condos market is regarded as one of the most coveted real estate markets in the entire USA.</div> </div> <span><a onclick="showHideDiv('postbody80');" style="font-weight:bold; font-size:80%;" title="Click to read related article.">Read/Hide: </a></span></div></div></div></DIV></TD></TR></TABLE>



<!--  ******  END COMPONENT  - ID:28382  TYPE:member_journal_view   *****  -->




<!--  ******  START COMPONENT - ID:28962  TYPE:text   *****  -->



<DIV    CLASS="SM_comp_text" ID="SM_comp_28962" >

<DIV  CLASS="SM_comp_content">
</DIV>

</DIV>



<!--  ******  END COMPONENT  - ID:28962  TYPE:text   *****  -->




<!--  ******  START COMPONENT - ID:28961  TYPE:link   *****  -->


<TABLE summary="" CELLSPACING="0"    CELLPADDING="0"   CLASS="SM_comp_link" ID="SM_comp_28961"><TR><TD ><DIV  CLASS="SM_comp_content">
<DL><DT><A class="SM_comp_link_url" HREF="http://"></A></DL></DIV></TD></TR></TABLE>



<!--  ******  END COMPONENT  - ID:28961  TYPE:link   *****  -->




<!--  ******  START COMPONENT - ID:28383  TYPE:text   *****  -->



<DIV    CLASS="SM_comp_text" ID="SM_comp_28383" >

<DIV  CLASS="SM_comp_content">
Register and sign in to post updates from your profile. They will echo here and on other selected pages of the site.</DIV>

</DIV>



<!--  ******  END COMPONENT  - ID:28383  TYPE:text   *****  -->


<br clear="all">

<!--  ******  START COMPONENT - ID:25389  TYPE:ad   *****  -->


<TABLE summary="" CELLSPACING="0"  ALIGN="center"   CELLPADDING="0"   CLASS="SM_comp_ad" ID="SM_comp_25389"><TR><TD ><DIV  CLASS="SM_comp_content">
<div class="SM_banner_ad" title="Decorate your home with functional art from Northwest Native Designs."><A HREF="http://sitemaker.clark-ip.com/util/ad_click.dwp?ad=63"  TARGET="_view" ><IMG  ID="SM_graphic_3930"  SRC="http://www.seattlepress.com/ads/sprs_345e5b69cc43.jpg" width="180" height="132"  ALT="banner_ad"  BORDER="0"></A></div></DIV></TD></TR></TABLE>



<!--  ******  END COMPONENT  - ID:25389  TYPE:ad   *****  -->


</DIV></TD></TR></TABLE>



<!--  ******  END COMPONENT  - ID:24995  TYPE:container_end   *****  -->




<!--  ******  START COMPONENT - ID:25165  TYPE:container_start   *****  -->


<TABLE summary="" CELLSPACING="0"  ALIGN="right"  WIDTH="48%"  CELLPADDING="0"   CLASS="SM_comp_container_start" ID="SM_comp_25165"><TR><TD ><DIV  CLASS="SM_comp_content">


<!--  ******  START COMPONENT - ID:13353  TYPE:blog_view   *****  -->


<TABLE summary="" CELLSPACING="0"    CELLPADDING="0"   CLASS="SM_comp_blog_view" ID="SM_comp_13353"><TR><TD >
<P  class="SM_section_title" ID="SM_section_title_13353">The News</P>
<DIV  CLASS="SM_comp_content">
<div class="SM_component_blog_post"><div class="SM_component_blog_post_title" ><a href="http://www.seattlepress.com/tools/blog.dwp?task=show_post&amp;post_id=6424">Net Neutrality on the Auction Block</A></div><div class="SM_component_blog_post_content" >In what universe is turning over unfettered control of the Internet to ISP and telecomm giants consistent with the core<span class="SM_more_link">... <A href="http://www.seattlepress.com/tools/blog.dwp?task=show_post&amp;post_id=6424">Continues...</A></span><BR clear="all"><div  style="width:100px;padding:5px; margin:auto;" class="blog_graphic" ID="blog_graphic_6424" ><A  TITLE="Click to enlarge." HREF="javascript:pop_win('http://www.seattlepress.com/graphics/sprs_d47b55daaace.png',576,332);" ><IMG  ID="SM_graphic_7944"  SRC="http://sitemaker.clark-ip.com/cache/gallery/sprs/sprs_d47b55daaace_scaled_100_auto.jpg" width="100" height="56"  ALT=""  BORDER="0"></A></div><BR clear="all"></div></div><div class="SM_component_blog_post"><div class="SM_component_blog_post_title" ><a href="http://www.seattlepress.com/tools/blog.dwp?task=show_post&amp;post_id=6418">Trump, Flynn and the Nature of Lying</A></div><div class="SM_component_blog_post_content" >I cannot be the only one who has realized Donald Trump has incriminated himself.<br>
<br>
Headline: “Trump tweets from<span class="SM_more_link">... <A href="http://www.seattlepress.com/tools/blog.dwp?task=show_post&amp;post_id=6418">Continues...</A></span><BR clear="all"><div  style="width:100px;padding:5px; margin:auto;" class="blog_graphic" ID="blog_graphic_6418" ><A  TITLE="Click to enlarge." HREF="javascript:pop_win('http://www.seattlepress.com/graphics/sprs_0b57d7e41d94.png',529,252);" ><IMG  ID="SM_graphic_7939"  SRC="http://sitemaker.clark-ip.com/cache/gallery/sprs/sprs_0b57d7e41d94_scaled_100_auto.jpg" width="100" height="46"  ALT=""  BORDER="0"></A></div><BR clear="all"></div></div><div class="SM_component_blog_post"><div class="SM_component_blog_post_title" ><a href="http://www.seattlepress.com/tools/blog.dwp?task=show_post&amp;post_id=6391">Latest Bad Health Care Idea Dies in Congress</A></div><div class="SM_component_blog_post_content" >The idea that abandoning our national affordable care system and turning over health systems policy to the states will<span class="SM_more_link">... <A href="http://www.seattlepress.com/tools/blog.dwp?task=show_post&amp;post_id=6391">Continues...</A></span></div></div><div class="SM_component_blog_post"><div class="SM_component_blog_post_title" ><a href="http://www.seattlepress.com/tools/blog.dwp?task=show_post&amp;post_id=6383">August Unemployment Marginally Up</A></div><div class="SM_component_blog_post_content" >OLYMPIA – The state’s seasonally adjusted unemployment rate increased slightly from 4.5 to 4.6 percent in August,<span class="SM_more_link">... <A href="http://www.seattlepress.com/tools/blog.dwp?task=show_post&amp;post_id=6383">Continues...</A></span></div></div><div class="SM_component_blog_post"><div class="SM_component_blog_post_title" ><a href="http://www.seattlepress.com/tools/blog.dwp?task=show_post&amp;post_id=6363">Rating Trump's Eligibility for Immigration on his own Scale</A></div><div class="SM_component_blog_post_content" >They're baa-aack. Now it's the RAISE Act (look up the stupid acronym yourself.)<br>
<br>
You need at least 30 points to be<span class="SM_more_link">... <A href="http://www.seattlepress.com/tools/blog.dwp?task=show_post&amp;post_id=6363">Continues...</A></span></div></div></DIV></TD></TR></TABLE>



<!--  ******  END COMPONENT  - ID:13353  TYPE:blog_view   *****  -->


<br clear="all">

<!--  ******  START COMPONENT - ID:25427  TYPE:comment_view   *****  -->



<A NAME="SM_comp_25427"></A>

<A NAME="SM_comp_Forum"></A>
<TABLE summary="" CELLSPACING="0"    CELLPADDING="0"   CLASS="SM_comp_comment_view" ID="SM_comp_25427"><TR><TD >
<P  class="SM_section_title" ID="SM_section_title_25427">The Conversation</P>
<DIV  CLASS="SM_comp_content">
<div class="SM_comment_view_header">Comments on news articles, commentaries and other features.</div><div class="SM_comment" style="margin-left:30px; text-indent:-30px;"><a href="http://www.seattlepress.com/tools/members.dwp?task=member_info&amp;member_id=8439">rees</a> - <span class="SM_comment_date">Dec 02, 2017</span> at <span class="SM_comment_time">12:45 PM</span>&nbsp;wrote:&nbsp;<span style="font-style:italic;">Corroboration from Washington Post!</span> <span style="white-space:nowrap;"> ...<A href="http://www.seattlepress.com/tools/qp.dwp?task=show_post&amp;post_id=6418" style="font-size:90%; font-weight:bold;">Read more</A></span></div><div class="SM_comment" style="margin-left:30px; text-indent:-30px;"><a href="http://www.seattlepress.com/tools/members.dwp?task=member_info&amp;member_id=8439">rees</a> - <span class="SM_comment_date">Oct 08, 2016</span> at <span class="SM_comment_time">1:10 PM</span>&nbsp;wrote:&nbsp;<span style="font-style:italic;">You might want to describe your thesis and the type of help you need.</span> <span style="white-space:nowrap;"> ...<A href="http://www.seattlepress.com/tools/forum.dwp?task=show_topic&amp;topic_id=93" style="font-size:90%; font-weight:bold;">Read more</A></span></div><div class="SM_comment" style="margin-left:30px; text-indent:-30px;"><a href="http://www.seattlepress.com/tools/members.dwp?task=member_info&amp;member_id=8439">rees</a> - <span class="SM_comment_date">Oct 03, 2016</span> at <span class="SM_comment_time">12:45 PM</span>&nbsp;wrote:&nbsp;<span style="font-style:italic;">Cannot help noticing growth everywhere but King & Snohomish. A charitable...</span> <span style="white-space:nowrap;"> ...<A href="http://www.seattlepress.com/tools/qp.dwp?task=show_post&amp;post_id=6260" style="font-size:90%; font-weight:bold;">Read more</A></span></div><div class="SM_comment" style="margin-left:30px; text-indent:-30px;"><a href="http://www.seattlepress.com/tools/members.dwp?task=member_info&amp;member_id=8439">rees</a> - <span class="SM_comment_date">Apr 09, 2015</span> at <span class="SM_comment_time">12:31 PM</span>&nbsp;wrote:&nbsp;<span style="font-style:italic;">This might get grandchildren to visit more often!</span> <span style="white-space:nowrap;"> ...<A href="http://www.seattlepress.com/tools/qp.dwp?task=show_post&amp;post_id=5941" style="font-size:90%; font-weight:bold;">Read more</A></span></div><div class="SM_comment" style="margin-left:30px; text-indent:-30px;"><a href="http://www.seattlepress.com/tools/members.dwp?task=member_info&amp;member_id=15585">Anonymous</a> - <span class="SM_comment_date">Mar 21, 2013</span> at <span class="SM_comment_time">3:50 PM</span>&nbsp;wrote:&nbsp;<span style="font-style:italic;">Operated by WithinReach, Apple Health for Kids (Children's Medical Insurance) is...</span> <span style="white-space:nowrap;"> ...<A href="http://www.seattlepress.com/tools/forum.dwp?task=show_topic&amp;topic_id=93" style="font-size:90%; font-weight:bold;">Read more</A></span></div><div class="SM_comment" style="margin-left:30px; text-indent:-30px;"><a href="http://www.seattlepress.com/tools/members.dwp?task=member_info&amp;member_id=1424">frankalexander</a> - <span class="SM_comment_date">Jul 14, 2008</span> at <span class="SM_comment_time">10:20 AM</span>&nbsp;wrote:&nbsp;<span style="font-style:italic;">Our Guess: Mr. Cooke is crying all the way to the bank. He should probably be in...</span> <span style="white-space:nowrap;"> ...<A href="http://www.seattlepress.com/tools/qp.dwp?task=show_post&amp;post_id=2125" style="font-size:90%; font-weight:bold;">Read more</A></span></div><div class="SM_comment" style="margin-left:30px; text-indent:-30px;"><a href="http://www.seattlepress.com/tools/members.dwp?task=member_info&amp;member_id=9110">editor-sp</a> - <span class="SM_comment_date">Dec 06, 2007</span> at <span class="SM_comment_time">10:47 AM</span>&nbsp;wrote:&nbsp;<span style="font-style:italic;">If you have news, please don't post it here in the forums. Use the To The Editor...</span> <span style="white-space:nowrap;"> ...<A href="http://www.seattlepress.com/tools/forum.dwp?task=show_topic&amp;topic_id=94" style="font-size:90%; font-weight:bold;">Read more</A></span></div><div class="SM_comment" style="margin-left:30px; text-indent:-30px;"><a href="http://www.seattlepress.com/tools/members.dwp?task=member_info&amp;member_id=9110">editor-sp</a> - <span class="SM_comment_date">Dec 06, 2007</span> at <span class="SM_comment_time">10:37 AM</span>&nbsp;wrote:&nbsp;<span style="font-style:italic;">You can participate in the discussion by registering as a member of the Seattle...</span> <span style="white-space:nowrap;"> ...<A href="http://www.seattlepress.com/tools/forum.dwp?task=show_topic&amp;topic_id=93" style="font-size:90%; font-weight:bold;">Read more</A></span></div><div class="SM_comment" style="margin-left:30px; text-indent:-30px;"><a href="http://www.seattlepress.com/tools/members.dwp?task=member_info&amp;member_id=7151">Anonymous</a> - <span class="SM_comment_date">May 01, 2007</span> at <span class="SM_comment_time">11:06 AM</span>&nbsp;wrote:&nbsp;<span style="font-style:italic;">I missed the shredathon, when is the next one in Lynnwood?</span> <span style="white-space:nowrap;"> ...<A href="http://www.seattlepress.com/tools/qp.dwp?task=show_post&amp;post_id=1506" style="font-size:90%; font-weight:bold;">Read more</A></span></div></DIV></TD></TR></TABLE>



<!--  ******  END COMPONENT  - ID:25427  TYPE:comment_view   *****  -->


</DIV></TD></TR></TABLE>



<!--  ******  END COMPONENT  - ID:25166  TYPE:container_end   *****  -->


</DIV></TD></TR></TABLE>



<!--  ******  END COMPONENT  - ID:29978  TYPE:container_end   *****  -->


</DIV></TD></TR></TABLE>



<!--  ******  END COMPONENT  - ID:29618  TYPE:container_end   *****  -->


<br clear="right">

<!--  ******  START COMPONENT - ID:24991  TYPE:ad   *****  -->


<TABLE summary="" CELLSPACING="0"  ALIGN="center"  WIDTH="100%"  CELLPADDING="10"   CLASS="SM_comp_ad" ID="SM_comp_24991"><TR><TD  ALIGN="center"><DIV  CLASS="SM_comp_content">
<div class="SM_banner_ad" title="Let Phoenix Builders create your new home or business using proven steel construction."><A HREF="http://sitemaker.clark-ip.com/util/ad_click.dwp?ad=114"  TARGET="_view" ><IMG  ID="SM_graphic_5254"  SRC="http://www.seattlepress.com/ads/sprs_9645930b7be2.jpg" width="468" height="60"  ALT="banner_ad"  BORDER="0"></A></div></DIV></TD></TR></TABLE>



<!--  ******  END COMPONENT  - ID:24991  TYPE:ad   *****  -->



</div>

<br clear="all"><!-- Page id:  -->
</DIV>
<!--  ******  end content_section_div  *****  -->
</DIV>
<!--  ******   end content_section_div  *****  -->

<!--  ******   END CONTENT SECTION   *****  -->


		
	</td>
	
	
</TR><TR>
	
	<TD id="footer"  class="SM_footer_content"  align="center" valign="middle">
		

<!--  ******  START FOOTER SECTION   *****  -->

<!--  *************  MEMBER BAR TEST  location: 8  ***********   -->

<!--  ******  FOOTER MENU   *****  -->


<div class="SM_site_text_menu">
<span  ID="SM_site_text_menu_item_active" onclick="location.href='http://www.seattlepress.com'" class="SM_site_text_menu_item"><a  href="http://www.seattlepress.com">INDEX</a></span><span class="SM_footer_menu_item_sep">&nbsp;&bull;&nbsp;</span><span  ID="SM_link_text_6786" onclick="location.href='http://www.seattlepress.com/members.html'" class="SM_site_text_menu_item"><a  href="http://www.seattlepress.com/members.html">Members</a></span><span class="SM_footer_menu_item_sep">&nbsp;&bull;&nbsp;</span><span  ID="SM_link_text_4749" onclick="location.href='http://www.seattlepress.com/about_spol.html'" class="SM_site_text_menu_item"><a  href="http://www.seattlepress.com/about_spol.html">About...</a></span><span class="SM_footer_menu_item_sep">&nbsp;&bull;&nbsp;</span><span  ID="SM_link_text_5237" onclick="location.href='http://www.seattlepress.com/policies.html'" class="SM_site_text_menu_item"><a  href="http://www.seattlepress.com/policies.html">Policies</a></span></div>

<!--  *************  MEMBER BAR TEST  location: 9  ***********   -->

<!--  ******   END FOOTER SECTION   *****  -->

	</TD>

</tr></table><!--  ******   END OVERALL PAGE TEMPLATE TABLE   *****  --><br clear="all">

<!--  ******   COPYRIGHT FOOTER   *****  -->


<DIV class="SM_copyright">&copy; 2017 Seattle Press & Clark Internet Publishing / Web support by <A HREF="http://www.clarkinternet.com">Clark Internet Publishing</A> &copy; 1996 - 2017</DIV><!-- This site is produced and published with Sitemaker(SM), Journalmaker&#8482; and other content management systems from Clark Internet Publishing Inc. (Clark IP) 1996 - 2017 , all rights reserved. Sitemaker is a comprehensive, browser-based system for building web sites with automated navigation and popular features like blogs, image galleries, article lists, newsletters, forums, calendars, etc. Clark Internet Publishing is not responsible for user-supplied content. -->

<script src="http://www.google-analytics.com/urchin.js" type="text/javascript"></script><script type="text/javascript">_uacct = "UA-4310775-1";urchinTracker();</script>

</BODY></HTML><!--  Script timer 0.03029 seconds. -->